
  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Technical Setup 
Version: CMS 5.4.6 



 

 

Document Ref: TEAM TemplaCMS Technical Setup v1.docx Version:  Page 2 | 28 

© Copyright 2021 TEAM Software by WorkWave TEAM Software by WorkWave | teamsoftware.com/legal 

 

COMMERCIAL STATEMENT 

This document is subject to any terms as per  teamsoftware.com/legal. 

  

teamsoftware.com/legal


 

 

Document Ref: TEAM TemplaCMS Technical Setup v1.docx Version:  Page 3 | 28 

© Copyright 2021 TEAM Software by WorkWave TEAM Software by WorkWave | teamsoftware.com/legal 

 

TABLE OF CONTENTS 

INTRODUCTION .................................................................................................................................. 4 

Applications ............................................................................................................................................................... 4 
IT Responsibilities ..................................................................................................................................................... 4 

SQL SERVER ....................................................................................................................................... 5 

SQL Server Back-ups: ................................................................................................................................................ 5 

TEMPLACMS ADMINISTRATION SUITE .................................................................................................... 5 

How to start the Administration Suite ...................................................................................................................... 6 

TEMPLACMS CLIENT APPLICATION ........................................................................................................ 7 

General ...................................................................................................................................................................... 7 
Client application on PC............................................................................................................................................ 7 

Client application via Terminal Services (or RDP) ................................................................................................... 7 

Emailing ..................................................................................................................................................................... 8 

TEMPLACMS MOBILE APPLICATION ..................................................................................................... 11 

Overview .................................................................................................................................................................. 11 
Schematic ................................................................................................................................................................ 11 

TEMPLACMS CUSTOMER PORTAL ........................................................................................................ 12 

ACCESS DIMENSIONS ........................................................................................................................ 13 

Activation ................................................................................................................................................................. 13 

Overview .................................................................................................................................................................. 13 
System Requirements ............................................................................................................................................. 13 

Installation............................................................................................................................................................... 13 
Connecting to Dimensions ...................................................................................................................................... 16 

Managing your License ........................................................................................................................................... 17 
Ongoing Maintenance ............................................................................................................................................. 18 

Emailing ................................................................................................................................................................... 18 

ACCESS SELECTPAY ........................................................................................................................... 20 

Initial Configuration ................................................................................................................................................ 20 
SelectPay Client Installation ................................................................................................................................... 20 

Logging In ................................................................................................................................................................ 22 

Quick Login Access .................................................................................................................................................. 23 
Ongoing Maintenance ............................................................................................................................................. 23 
Emailing ................................................................................................................................................................... 23 

CENTRAL FOLDER STRUCTURE & PERMISSIONS .................................................................................... 26 

TemplaCMS.............................................................................................................................................................. 26 

Access Dimensions .................................................................................................................................................. 26 

Access SelectPay ..................................................................................................................................................... 27 

 

  



 

 

Document Ref: TEAM TemplaCMS Technical Setup v1.docx Version:  Page 4 | 28 

© Copyright 2021 TEAM Software by WorkWave TEAM Software by WorkWave | teamsoftware.com/legal 

 

INTRODUCTION 

Applications 

The following TemplaCMS applications exists: 

● TemplaCMS – this is the main system, which is client/server software and which is installed on a desktop/laptop, 

with an administration suite running on the central server – see section 4 

● TemplaCMS Mobile application – this is a standalone app that runs on an iPad and most Android mobile devices at 

4.4.2 or above – see section 5 

● TemplaCMS Customer Portal – this is a website that links into TemplaCMS to pull certain information (as required) 

from the main system – see section 6 

The following Access applications may exist: 

● Dimensions – this is the Access Accounts system 

● SelectPay – this is the Access Payroll system 

IT Responsibilities 

The following are the responsibility of the client’s internal IT department or their external IT provider (not Templa): 

Server level: 

● Remote access, e.g. for Templa, time & attendance or janitorial suppliers, remote staff, etc 

● Server – procurement, installation, setup, maintenance, performance, etc 

● VM Ware / virtualization – procurement, installation & setup, if required 

● SQL Server – procurement, installation, setup, permissions, etc 

● Backups – scheduling, running, checking, on/off site considerations, etc. 

● Disaster Recovery  

● Network – users, access, permissions/security, performance, etc 

● Document Store – management & volumes, e.g. photos, forms, etc. 

● TemplaCMS Administration Suite – permanently running job 

● Transaction & Event Log management 

Client level: 

● Client – installation of TemplaCMS or Access software on all PC’s, laptops, etc. 

● .Net framework 4.5 – installation on all PC’s, laptops, etc. 

● MS Office – procurement, installation, setup, etc 

● MS Exchange/Outlook – procurement, installation, setup, integration, etc  

● Redemption.dll – installation as required on all PC’s, laptops, etc. 

● BACS software 

● Remote client access 

TemplaCMS Mobile application and/or Customer Portal: 

● Separate server, as required  

● IIS – installation, setup, etc. 

● Mobile devices – procurement, setup, lock-down, download of TemplaCMS application, etc 

● SSL certificate – procurement and application, as required  

● Website – livery (branding), linking, button design, etc 

The following sections provides further guidance on how some of the above items should be installed. 
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SQL SERVER 

The following editions of Microsoft SQL Server are currently supported: SQL Server 2008 R2, SQL Server 2012.  

The default installation for SQL Server should be sufficient. Please ensure that the corresponding SQL Server Management 

Studio is also installed, and that SQL Server is configured to Mixed Mode authentication. Please ensure that the SA password 

is provided to Templa or alternatively the details of the Widows User that has full admin rights on the SQL server. 

The SQL Server instance name should also be provided to Templa.  

All back-ups taken from within in the applications will use the default SQL Server back-up location as specified during the SQL 

Server installation process – it is the responsibility of the customers IT provider to ensure that the default back-up location is 

set up to point to the location where back-ups should be kept. 

SQL Server Back-ups: 

In addition to the standard back-up plan for the server we recommend that SQL Server specific back-ups are scheduled via a 

SQL Server maintenance plan. If something goes wrong that only affect the drive SQL server data is on or if only one of the 

databases has an issue it is easy for Templa to restore a single database rather than the IT provider having to get involved in a 

restore / roll back the server to a previous state. 

To set up a SQL Server Maintenance / Back-up plan please have a look the following links: 

● https://technet.microsoft.com/en-us/library/ms189036(v=sql.105).aspx 

● https://msdn.microsoft.com/en-us/library/ms191002.aspx 

Further, customers should ensure regular SQL database transaction log backups are set up if full database recovery  

is required. 

Please note that Templa do not take any responsibility for our customer’s back-ups and do not get involved in any of the 

above setup. 

TEMPLACMS ADMINISTRATION SUITE 

The ‘TemplaCMS Administration Suite’ comprises three applications: 

● Workflow – this controls the workflow authorisation process for all modules within the TemplaCMS application. 

● Gateway – this handles the two-way integration requirements between TemplaCMS and any other application  

(e.g. for the collection of time and attendance information). 

● Batch – this runs all other scheduled background jobs. Note that your TemplaCMS may be configured to run more 

than one batch queue/application for performance optimisation. 

TemplaCMS is designed for these applications to be left permanently running on your server, they should be run under the 

user id that Templa will be using to remote access in. This user must be left logged in permanently in order to allow the 

applications to run. 

Icons exist on the main TemplaCMS frame (towards the bottom right) to indicate to the end user that these three  

sub-applications are running: 

 Sub-application is active 

Sub-application is inactive 

Sub-application status is unknown (network visibility issue) 

If any of the sub-applications are not running then the above icon will show as inactive. This should be resolved immediately. 
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How to start the Administration Suite 

If the user the administration suite was running under is logged off or the server is restarted then the sub-applications will be 

closed. The services can be started by double clicking the batch file StartCMSServices.bat on the desktop of our user on  

your server. 

If this needs to be done outside of our office hours, it is possible to run them from another user/PC (by double clicking the 

batch file StartCMSServices.bat), however Templa should be informed as soon as our office hours resume so we can close 

them and run them under our user again. 
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TEMPLACMS CLIENT APPLICATION 

General 

TemplaCMS requires MS.NET framework version 4.5 to run, this is generally pre-loaded on Windows 7 and later.  Please note 

that MS.NET framework version v4.5 is not compatible with Windows XP. 

Generally, the client is held centrally on a shared network location to which all users have access. As this is the usual setup the 

rest of this document will refer to TemplaCMS set up in this configuration. 

It is possible to install TemplaCMS on each PC, however this configuration requires updates to be rolled out manually to  

each desktop. 

TemplaCMS communicates directly with the SQL Server using SQL authentication, in order to allow this connection, the port 

which your SQL server is running over must be allowed upstream and downstream connection over TCP between the PC and 

the server.  This port can be found on your SQL server under: 

Microsoft SQL Server Configuration Manager > SQL Server Network Configuration > 

Instance which TemplaCMS uses > TCP/IP properties > IP Addresses Tab > Ports listed 

under IPAll 

Client application on PC 

TemplaCMS is run directly from a share on the server, the executable is located in the ‘Client Suite’ folder of the install. To 

give a user access to the program simply place a shortcut on their desktop to TemplaCMS.exe if they are running 64bit 

Outlook or TemplaCMS32 if they are running 32-bit Outlook, for example: 

\\SERVER\\TemplaCMS\Client Suite\TemplaCMS32.exe 

Please refer to the grid below to ensure that you are using the correct executable: 

Windows version Outlook version TemplaCMS executable 

64-bit 32-bit TemplaCMS32.exe 

64-bit 64-bit TemplaCMS.exe 

32-bit 32-bit either 

Client application via Terminal Services (or RDP) 

Some companies install MS terminal services if they have a large number of external users that need to remotely connect; 

alternatively they could RDP into a nominated available PC on your network.  For remote access to the TemplaCMS client 

application, the installation of a ‘Terminal Server’ is recommended.  As a guide for scaling, a single instance of the 

TemplaCMS client requires in the range of 100-500mb of memory, depending on the functions performed. 
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Emailing 

HOW IT WORKS 

TemplaCMS email integration can be configured in one of four ways; the system wide setup is configured by Templa, this can 

be overridden on a per-user basis within the software. 

● Microsoft Outlook – emails can be sent directly through the Outlook client of the user who is running the 

application. This requires Outlook to be installed and open on the PC.  Any sent email will appear to have been 

manually sent by the logged in Outlook user, and will be recorded in their ‘sent items’. Note that Outlook will also 

need to be installed on the server for system sent emails. 

● Novell Groupwise – identical integration to that provided for Outlook. 

● SMTP server using Windows Authentication – this option allows emails to be relayed directly to a local SMTP 

server, rather than via a mail client application.  For this to function correctly all users must be able to relay to your 

SMTP server using the windows authentication of the user which the application is running under.  You will need to 

provide Templa with the name of the SMTP server and the email address you wish to use as default. 

● SMTP Server using SMTP Authentication – this option allows emails to be relayed directly to an (internal or 

external) SMTP server using SMTP authentication. You must provide Templa with the SMTP server, port, whether the 

connection uses SSL, the email address, the username and the password for the default account you wish to send 

through. 

In all of the above configurations the default email configuration can be overridden on a per-user basis on each user’s record. 

This is configured under Maintenance > User Access/Security > Users > User > General and Email tabs. The default email 

configuration will always be used for system emails. 

The default for all users on the system is set in the configuration file of the TemplaCMS and heartbeat executables, this can 

then be overridden for each user on their user record under Maintenance > User Access/Security > Users > User > General and 

Email tabs.  

Note: System-sent emails will be sent using the credentials set on the user record of the master workflow user. 

The default is set in the config files under the setting named email provider, below is an example: 

<setting name="emailprovider" serializeAs="String"> 

<value>SMTP:smtp.smtpserver.com:587:true:dftemail@domain.com:dftpwd</value> 

</setting> 

Note: This can be tested by emailing something (eg. a timesheet) to yourself. 

Note: If you are asked to test with ‘User secure connection’ ticked and it does not work then you should test without it ticked. 

METHODS 

See next page (landscape). 

ADVANCE OUTLOOK INTEGRATION (AOI) 

In addition to the system wide emailing out setup (above & below), TemplaCMS can interface with MS Outlook in order for 

users to use the quick email functionality and attach emails to records within TemplaCMS.  Please note for this to function MS 

Outlook must be installed on the same PC that TemplaCMS is running on. 

Some further configuration is required for this. In order for TemplaCMS to communicate with Outlook, a DLL called 

Redemption.dll must be registered.  To do this run Install.exe from \\SERVER\TemplaCMS\Client Suite\Redemption\  Please 

note that if Access Dimensions is installed on the PC then this does not need to be run as Dimensions will register this 

automatically. 

In addition to registering Redemption.dll you must also ensure you are running the same version (32/64-bit) of TemplaCMS as 

the MS Outlook that is installed on the PC, as detailed in “Client application on PC” above

file://///SERVER/TemplaCMS/Client%20Suite/Redemption/
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Methods 

Method How it works Config File Setup Requirements 

Microsoft 

Outlook 

Emails are sent directly through the Outlook of 

the user who is running the application. Sent 

emails will appear in the users Sent Items 

<value>outlook</value> 
● Outlook to be open and running on all user PCs and 

the server 

● Outlook will also need to be installed on the server for 

system sent emails 

Novell 

Groupwise  

Identical integration to that provided for 

Outlook. Obsolete/not generally used any more 

  

SMTP server 

using Windows 

Authentication 

Emails are relayed to a local SMTP server. All 

users must be able to relay to the SMTP server 

using the windows authentication of the user 

which the application is running under 

<value>SMTP:smtp.smtpserver.com:dftemail

@domain.com</value> 

● smtp.smtpserver.com = SMTP server name/ip address 

● dftemail@domain.com = Default email address (Can 

just use TemplaCMS@domain.com) 

SMTP Server 

using SMTP 

Authentication  

Emails are relayed to an (internal or external) 

SMTP server using SMTP authentication. (The 

same as Dimensions and SelectPay). Note that if 

the SMTP user is different to the email address, 

then this will have to be entered on the TCMS 

master user’s user record 

<value>SMTP:smtp.smtpserver.com:587:true:

dftemail@domain.com:dftpwd</value> 

● smtp.smtpserver.com = SMTP Server name/ip address 

● 587 = Port 

● true = Whether the connection uses SSL (true/false). 

● dftemail@domain.com = Default email address (Can 

just use TemplaCMS@domain.com) 

● dftpwd  = SMTP Password 

● SMTP user = if different to the email address, then this 

should be set on the TCMS master user record 
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EVENT LOG NOTIFICATIONS 

Any event logs produced by the system will be automatically emailed to the email address setting called 

“supportemailaddress” set in the config file of cms and the heartbeats. See an example below. 

<setting name="supportemailaddress" serializeAs="String"> 

<value>support@templa.com</value> 

</setting> 

WHAT WE REQUIRE FROM THE CUSTOMER 

This depends on whether they wish to use Outlook, Windows authentication or SMTP authentication… 

● Windows authentication: 

● SMTP server 

● The default email address 

● SMTP authentication: 

● SMTP Port 

● SMTP server 

● The default email address 

● Whether it uses SSL 

● The default email address 

● The default username (SP Only) 

● The default password 

Note: No further details are required for MS Outlook. Simply amend the config file. 

  



  

Document Ref: TEAM TemplaCMS Technical Setup v1.docx Version:  Page 11 | 28 

© Copyright 2021 TEAM Software TEAM Software | teamsoftware.com/legal 

TEMPLACMS MOBILE APPLICATION 

Overview 

This is a standalone application that runs on an iPad and most* Android mobile devices at 4.4.2 or above; as such, a demo 

version can be downloaded from either: 

● https://itunes.apple.com/gb/app/templacms-mobile/id660627366?mt=8 

● https://play.google.com/store/search?q=TemplaCMS&c=apps 

The files that pass between the main TemplaCMS system and these mobile devices (or tablets) utilize IIS, although there is no 

website per se, as per the schematic overleaf, where a SSL cert is required.  The Mobile application allows contracts to be 

viewed, QA’s to be completed, Stores Order Requests to be raised, etc – but not timesheets.  

* if Android (rather then iPad) mobile devices are to be purchased for our TemplaCMS Mobile application, then please ensure 

that our TemplaCMS Mobile application works on one such device/model to be purchased, before purchasing multiple such 

devices, as a number of (cheaper) Android devices are not fully HTML5 compliant and/or have bespoke web browsers.  

Many remote managers at our other clients have both a PC/laptop and a mobile device.  However some clients have 

purchased a tablet with a keyboard (e.g. ASUS Transformer TFxxx 10”) so that their managers can run the TemplaCMS Mobile 

application on the tablet but also access the main TemplaCMS software via an RDP session from this tablet.  We would 

normally recommend a 10” (i.e. not 7” or 8”) tablet and certainly if the tablet was to have a dual purpose, given the 

complexity of the timesheet entry screen.    

Consideration should also be given as to whether the tablets should be Wifi or 4G – the former is the more normal and 

cheaper route, especially given the managers could be uploading relatively large picture files as part of a Quality Audit; in 

which case the managers would normally be expected to sync their devices daily or whenever they have a Wifi connection, 

e.g. when they come into the office, at home, in McDonalds/Starbucks, etc. 

Schematic 

 

Data messages are held on the TCMS-MG server in secured folders as text files, meaning there is no need for MS/SQLServer to 

be installed.  Once a message is confirmed as received by the target mobile device or server, the message will be removed 

from TCMS-MG.  As such the volume of data held within TCMS-MG at any given time will be relatively small.  Due to its 

transitory nature no data will exist within TCMS-MG that cannot be re-created if necessary, however a scheduled file system 

backup should be implemented.  This will backup any pending messages that are waiting to be sent to the server or mobile(s), 

as well as the file structure and therefore the device configuration details.    

Interaction between the TemplaCMS server and TCMS-MG is handled via the TemplaCMS Gateway and so will be 

automatically triggered as and when necessary.   Interaction between the mobile device and TCMS-MG will be handled by the 

mobile device user deliberately requesting to ‘sync’.   In this way unnecessary mobile data usage will be avoided, as will 

potential conflicts where a user is in the process of updating data. 

  

https://itunes.apple.com/gb/app/templacms-mobile/id660627366?mt=8
https://play.google.com/store/search?q=TemplaCMS&c=apps
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TEMPLACMS CUSTOMER PORTAL 

To be confirmed 
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ACCESS DIMENSIONS 

These instructions are provided as a guide for the installation of the Dimensions Accounts software. However, we recommend 

the installation and configuration on the server is carried out by Templa. 

Activation 

There are several steps to installing and activating your software:  

● Prepare the Database Server and its environment. See System Requirements for the supported database servers. 

● Install the Dimensions Accounts software.  

● Link the Accounts software to the Database via an ODBC connection – the instructions for this are included here and 

as well as the install instructions for the SQL Server Express software. 

Overview  

The following consideration need to be born in mind: 

● It is very important that the System Requirements are met fully; please review these before commencing installation.  

● As with all other software installations, we recommend that no other applications are running when installing these 

applications.  

● The Crystal v12 Print Engine is installed as a default; in case of any issues it is advisable to install an earlier version of 

Crystal. You can install an earlier version of Crystal by selecting Custom Install.  

● Please note that Crystal 12 cannot be installed on 64-bit operating systems, or on Windows 8. 

System Requirements  

● Supported Operating Systems: Vista, Windows 7, Windows 8, Windows Server 2003, Windows Server 2008 or 

Windows Server 2012.  

● Microsoft SQL Server 2008 and later  

● Dimensions Accounts makes use of the Microsoft® .NET Framework version 2.0, .NET Framework 3.5 SP1, .NET 

Framework 4.0, Office Web Components 11 and Microsoft Visual C++ 2005 redistributable. If these are not installed 

you will be prompted to install them when you start installing the accounts.  

Caution: When installing Access Accounts on Windows Server 2012 you may receive a message advising that Microsoft.NET 

Framework 2.0 could not be installed. You should open the Server Manager Dashboard and choose ‘.NET Framework 3.5 

Features’ from the list of features within the ‘Add Roles and Features Wizard’.  

● For SQL Server and SQL Server: the appropriate SQL Native Client driver must be installed on your client workstation.  

● You will also need Internet Explorer v6 or higher, a Processor Speed of 266MHz or higher, and at least 256mb of RAM. 

Installation  

On each Client Workstation, insert the Access Dimensions CD and follow these instructions: 

1. If the Home Page does not launch automatically after a few moments, select Start > Run, and on the dialogue 

window enter X:\Setup.exe (where “X” is the drive identity of your CD-ROM) 

2. When the Access Dimensions CD Home Page is displayed, select Accounts from the list of Dimensions applications. 

Selecting this will display application information and an Installation menu containing links to: 

● the Accounts installation,  

● the View Detailed Installation Guide (PDF) function  

3. Select the ‘Accounts’ option to install the Access Dimensions client on the user pc.  Each installation option will 

display simplified installation instructions. 
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RUNNING THE INSTALL PROCESS 

● Select the ‘Accounts’ install option from the installation page  - this will display a warning message about opening or 

saving files. Select Open/Run and the Installation will start 

● The installer will also detect if pre-requisite applications are installed. If not, then you are prompted to install these 

when you start installing the accounts 

● The Welcome window is displayed, advising you to quit all other applications before continuing; when you have done 

so, click on Next 

● Cancel – you can press Cancel at any time to exit the set-up wizard 

● User Information – Enter the details required, and click on Next 

● Destination Folder – confirm that the suggested install location is acceptable. You can click on Browse to change the 

location and select or create an alternative. An alternative location can be created by typing the path into the Folder 

name field 
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● Click Next 

 

 
 

● Select Installation Type; then click Next:  

o Typical - This would be the normal choice. 

o Custom - Only select this if you want to choose which application features you want to install. If you wish to 

install Crystal v11 or v9 Print Engine, select Custom Install and change the selection accordingly. 

● If you have selected Custom, an additional Select Features window is displayed.  This shows the elements that will 

be installed by default (i.e. all except Miscellaneous and earlier versions of the Crystal Reports Print Engine) and the 

location on your hard disk where they will be installed.  

 

 
 

● Click on the elements to change the selections. When ready, click Next. 

● If you have selected Typical, or have been through the Custom window, the Ready to Install the Application window 

is displayed. Click Next. 

 

 
 

● If you have selected Typical, or have been through the Custom window, the Ready to Install the Application 

window is displayed. Click Install.  The installation will proceed.  When the installation is complete, click on Finish.  
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Connecting to Dimensions  

Please read the below section ‘Managing your license’ below before continuing. 

● To launch Dimensions open the Start menu and select ‘Access Applications   > Dimensions’ or alternatively create a 

shortcut to the application on the users desktop 

● When the Database Selection window is displayed, select the ‘Other’ Database option 

● On the Log In window, click on the lookup button adjacent to the ODBC Data Link. On the MS SQL Server Data Links 

window, select Insert.  

 

 
 

● On the New MS SQL Server Data Link window:  

a) Type in a Name for your link, e.g. DimensionsLink1.  

b) Enter a Description, if required.  

c) Then type in the Name of the machine (e.g. your Server) on which the data engine has been installed.  

● If you are using SQL Server Express, this can be seen on the SQL Server Service Manager window.  

● If you have installed a Named Instance of the data engine, the Name should be typed as: Server Name\Name Of 

Instance, e.g. DMSERVER\MYINSTANCE. If only the server name is entered, the default instance will be selected.  

● When complete, click the light bulb icon to ensure the connection is valid. A ‘Test Log In Details’ window will be 

displayed: 

 

 
 

● Enter the details of the SQL Server SA user or the Dimensions user’s details (check with Templa if needed). 

● If the link has been set-up correctly the following message will be displayed: 

 

 
 

● In case of any issues with the above the first thing to check would be if there is a firewall between the user pc and 

server blocking the default TCP and UDP  SQL Server ports may need to be opened on the Firewall. 
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● Once above tested successfully click on the lookup button adjacent to the Database option, selected the relevant 

accounts database name and clicked Logon: 

 
● The user will be prompted with the license screen on first time use. For further details please see ‘Managing your 

License’ section. 

Managing your License 

MANUALLY MANAGE YOUR LICENCE  

TEAM Software will manually apply the license key to the software install on the server.  This can also be done on the user 

pc’s but this can be changed after the initial install, if required.  Once logged on the “Software Registration” window will be 

displayed. Clicking on Edit allows the user to enter Reference, Licensee, Number of Users and Unlock Key.  

 

Click Register and you are taken back to the Licence Check Utility and your licence is shown in the Local Licence region. 

USING THE SHARING CAPABILITIES  

When the new licence details are shown in the Local Licence region and you have entered a ‘Central licence location’ on your 

local network, you can click the ‘Upload local Licence to Server’ button.  This saves the licence to the Central licence location 

and makes it available to share with your users.  When you have uploaded the licence, the details are shown in the Server 

Licence region, and should match your Local Licence details.  

The ‘Upload local Licence to Server’ button is disabled until you have downloaded or manually entered your licence details 

and have entered a Central licence location.  

DOWNLOADING SERVER LICENCE   

The ‘Central licence location’ needs to be configured for each user to enable the licence sharing capabilities.  When each of 

the users next logs on, they should navigate to the Change Registration Details function and enter the Central licence 

location. They should then click the ‘Download Server Licence’ button. When they have downloaded the licence, the details 

are shown in the Local Licence region, and should match the Server Licence details.  

Each time a user subsequently logs on, the system will automatically check that their local licence in sync with the server 

licence.  
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Ongoing Maintenance 

Every so often, a new version of Access Dimensions will be released.  If important or extensive new features are introduced 

then Templa may provide details of the new version.  Otherwise, a periodic upgrade (e.g. every 2-3 years) should be 

considered, not least so as to ensure Access Dimensions is compatible with the latest versions of MS Windows Server,  

MS SQL Server, etc.  

SERVICE PACKS & HOT FIXES 

Occasionally additional Service Packs for Access Dimensions will be issued to make Dimensions compliant with the legislative 

changes issued by HMRC or to fix reported issues with the software. Service Packs are dependent on the version of 

Dimensions and TEAM Software will inform all customers if Service Packs relevant to their version of Dimensions need  

to be installed.  

Service packs and hot fixes will be copied to the server, as and when required by Templa.  They will be saved in the 

installation files folder (please contact Templa for confirmation of this location) and installed on the server at a pre-arranged 

time. The installation details will vary depending on the nature of the service pack or hot fix so can only be advised upon 

when released.  It will be your responsibility to arrange the installation of these upgrades / updates on user PCs.  

Emailing 

HOW IT WORKS 

Emailing out of Dimensions works in two ways; via Outlook and via relaying to the SMTP server. Versions prior to v2.50h send 

all emails through the Outlook running on the same windows session that Dimensions is running under. Versions later than 

v2.50h will send individual emails (like re-sending an invoice copy from a customer transaction list) will be sent via the user’s 

Outlook, whereas batched transactions will be sent via SMTP. Please note that at present only 32bit outlook is supported.  

When batched transactions (such as batched invoices from CMS) are sent via SMTP, the emails are relayed directly to the 

SMTP server and therefore do not appear in the user’s local MS Outlook Outbox.  

A default for all users is configured under System > Options > System Control Options > System Format > System Email 

Defaults.  This can be overridden on a per user basis under System > User Records > Email and System > User Records > 

Options.  Please see an overview below with additional information in the Access Dimensions Help. 

WHAT IS REQUIRED? 

The below credentials are required to set up the default SMTP account, this can be overridden on a per user basis: 

● SMTP server 

● SMTP Port 

● Whether it uses SSL 

● The default email address 

● The default email address username 

● The default email address password 

● Email account name 
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SETTING UP EMAILING VIA SMTP SERVER 

1. The default email address for batched transactions is set under System>Options>System Control Options>System 

Format>System Email Defaults. 

a. Set an email encryption password (I set this to Templa156). 

b. Click on the SMTP Servers icon (small picture of a computer) to add an SMTP server. Add the following and 

click save:  

i. Name - can be anything; just a name for the server. 

ii. Address – SMTP server name or IP address. 

iii. Port – usually 25.  

iv. Use SSL – Whether the connection uses SSL. 

v. Timeout in ms – The timeout for relaying the emails in ms. 

c. Click on the SMTP users icon (small picture of a face) to add an SMTP users. Add the following and click save: 

i. SMTP Server – Select the SMTP server you have just added. 

ii. User name – The SMTP username for the email account you wish to use. 

iii. Password - The SMTP password for the email account you wish to use. 

iv. OR instead of a username and password, default credentials can be used (NT authentication?) by 

ticking the use default credentials checkbox. 

d. On the System E-mail Defaults window enter: 

i. E-mail - The email address you wish to use. 

ii. E-mail name – the name you wish to be displayed to those who receive these emails. 

iii. Copy E-mail to (optional) – this allows an email address to be specified which all sent emails will 

automatically get copied to. A rule can be set on this account to place all of these emails in the sent 

items to maintain a record of what has been sent. 

iv. SMTP Server – Select the SMTP server you configured in part b. 

v. SMTP User – Select the SMTP user you configured in part c. 

2. The above default SMTP details can be overridden on a per user basis. To do this: 

a. Under System>User Records>Options click edit and set the E-mail Setup setting.  

i. Select SMTP if you wish to send batched emails via SMTP server. (Note this must be done for all 

users who wish to use the default SMTP credentials). 

ii. Select MAPI if you wish to configure Dimensions to send through Outlook. 

b. Under System>User Records>Email you can override the default SMTP server by either entering MAPI details 

or overriding SMTP details. Note that the servers and users must initially be configured under 

System>Options>System Control Options>System Format>System Email Defaults. 
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ACCESS SELECTPAY 

Initial Configuration 

An Access SelectPay installation is made up of a suite of the following components: 

● SelectPay Administrator 

● SelectPay Service 

● SelectPay Reports Administrator 

● SelectPay Client 

All these will be installed on your server by Templa, it is then your responsibility to install the client on all of your user PCs 

which require it.   

The SelectPay client will communicate with your payroll databases via the SelectPay service over port 65200.  Therefore you 

must ensure that any firewalls allow an upstream and downstream connection over TCP over port 65200 between your 

database server and any user PCs on which SelectPay is installed. 

SelectPay Client Installation  

On each Client Workstation, insert the Access SelectPay CD or downloaded SelectPay Install files and follow these 

instructions: 
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1. If the Home Page does not launch automatically after a few moments, select Start > Run, and on the dialogue 

window enter X:\Setup.exe (where “X” is the drive identity of your CD-ROM) 

2. Alternatively if the files have been downloaded and extracted, right click on the Setup.exe application file and run as 

administrator which will open the installation web pages 

3. When you run the Setup.exe file the installation pages will open with Internet Explorer. If your default browser is 

Internet Explorer (version 6 or later), double-click the setup file. If Internet Explorer (version 6 or later) is not installed 

on your computer, and you double-click the setup file, it may prompt you to install internet Explorer. If so, please 

follow the on-screen instructions. Once it has installed, double-click the setup file again 

4. The downloaded installation files are the same files that are used to run the CD, and as such the installation pages 

refer to the SelectPay CD throughout. There is a SelectPay CD introduction screen which appears as soon as you run 

the Setup.exe file. This will describe what is available to be installed and contain links to the instructions and latest 

features. There is a link to install prerequisites, to install SelectPay and to explore the CD 

5. Select the ‘Install SelectPay’ option which will launch the installation wizard 

 

 
 

6. The SelectPay Installation Wizard – This wizard will guide you through the installation process. Each screen will have 

a Next button in the bottom right-hand corner, and a ‘back’ arrow in the top left hand corner (excluding the first 

screen). There is also a Help button in the top right-hand corner of most screens, to assist you with that step of the 

installation.  

● The first screen advises that if you use certain Access Applications you will need to temporarily stop the services 

during the installation of SelectPay. This is to prevent any errors and ensure a successful install. This is not necessary 

if only the Client application is to be installed.  Click Next to continue. 

● User Information – The User Information details will be pre-populated with the credentials of the user currently 

logged into the machine. Please check that this is correct or enter the user details required for your organisation.  

● Confirm that the default install destination folder is an acceptable location. You can click on Browse to change the 

location and select or create an alternative folder.  

● Installation Type – this step will allow you to choose a Client Only or Custom installation. To install the Client on a 

user PC please select ‘Client Only’ 

 

 
 

● Feature Selection – Depending which option you selected on the Installation Type screen, one or all of the boxes will 

be ticked (excluding the Integration Web Service, which will need to be ticked if required). Click Next to continue  
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● Ready to Install – This is the final screen of the SelectPay wizard). This screen will tell you which features are ready to 

be installed, depending on your selections during the previous steps in the wizard. When you are happy with the 

selection click Install to start the installation  

● Once the installation is complete, the wizard will confirm that SelectPay 2.6 has been successfully installed on your 

system. You will also have access to the ‘What’s New’ document at this point.  

● Your chosen SelectPay features should now be installed and available from your start menu. 

Logging In 

1. Navigate to Start >> All Programs >> Access Applications >> SelectPay v2.6 >> SelectPay.  

2. On the log on screen enter the user name, password and database name:  

 

 
 

3. Click the ‘>>’ button, and tick Change Connection Details.  

● In the TCP Server field enter the name of the computer on which the SelectPay Service is installed.  

● Enter the port number on which the SelectPay Service is installed in the Port field:  

 

 
 

4. Logon to access your Access SelectPay database.  
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Quick Login Access  

If you have several databases you can set up a quick login connection for each of them by creating a new connection name.  

1. On your SelectPay login screen, select the dropdown menu labelled ‘Connection’ and select ‘New…’  

 

 
 

2. You can now assign a name for your connection and enter the user details and database name of the file you wish to 

connect to, then log in.  

 

 
 

3. Once you have logged in, this connection will be available in the dropdown menu for quicker access going forwards.  

Ongoing Maintenance 

Each year prior to the payroll year end (April) a new version of SelectPay will be released; Templa will contact you prior to this 

to coordinate the upgrade.  Whilst Templa will perform the installation and data upgrade on the server, it is your 

responsibility to install the new version of the software on your user PCs.  

SERVICE PACKS & HOT FIXES 

Occasionally additional Service Packs will be issued to make SelectPay compliant with the legislative changes issued by 

HMRC or to fix reported issues with the software.  Service packs and hot fixes will be copied to the server, as and when 

required by Templa.  They will be saved in the installation files folder (please contact Templa for confirmation of this location) 

and installed on the server at a pre-arranged time. The installation details will vary depending on the nature of the service 

pack or hot fix so can only be advised upon when released.  It will be your responsibility to arrange the installation of these 

any client fixes, where relevant, on user PCs.  

Emailing 

HOW IT WORKS 

Payslips and P60s can be emailed to employees from SelectPay. This is set up per database within SelectPay under System > 

Application Configuration > System Configuration > Communication Tab. 
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The following details are required: SMTP Server, SMTP Port, whether it uses a secure connection, the level of authentication 

(none, SMTP or NT), username and password (optional depending on authentication type), email address and the email 

display name.  

METHODS 

Authentication How it works Requirements 

None Emails are relayed to the SMTP server 

with no authentication 

SMTP server 

SMTP Port 

Whether it uses a secure connection 

The email address 

Display name 

Basic (SMTP)  Emails are relayed to the SMTP server 

using the SMTP credentials supplied. 

SMTP server 

SMTP Port 

Whether it uses a secure connection 

The email address 

The email address SMTP username 

The email address SMTP password 

Display name 

NT (Windows User) Emails are relayed to the SMTP server 

using NT/windows authentication 

SMTP server 

SMTP Port 

Whether it uses a secure connection 

The email address 

Display name 

HOW IT IS SET UP? 

Under System > Application Configuration > System Configuration > Communication Tab. 
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Note: This can be tested by changing the email address on an employee record to yours and emailing their payslip to yourself. 

Note: If you are asked to test with ‘User secure connection’ ticked and it does not work then you should test without it ticked.  

FURTHER SETUP 

Under Payroll>Employees>Employee>Personal tab there is a field for email address and tickboxes to email: payslips, P60s 

and P11Ds. There is also the option to enter a PDF encryption password for any documents sent to the employee. 

To email any documents to an employee, their email address must be entered. If you want to send documents using email as 

the default method then you will need to tick to tick that document type to email. 
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CENTRAL FOLDER STRUCTURE & PERMISSIONS 

TemplaCMS 

This must be held on central network drive that is visible to all client users as well as the administration application.  The 

access to this folder must be consistent from all points which can be achieved as a consistently mapped drive letter or by 

using a full directory/folder (UNC) path. 

The central folder contains the following areas which need the following permissions: 

Admin Suite N/A  

Client Suite Read/Execute  

Event Log Read/Write  

Gateway Read/Write/Modify This folder has a sub folder structure for each external system with which 

TEMPLACMS communicates.  Within this structure, sub-folders cause 

TEMPLACMS to keep a permanent record of files exchanged externally, either 

successfully (in an /done sub-folder) or un-successfully (in  

an /error sub-folder) 

Logos/Images Read This folder contains any company logos required in the production of the 

TemplaCMS documentation 

Semaphore Read/Write/Modify This folder contains no data but simply empty files, the existence of which 

controls the internal TEMPLACMS alerts process; this is done using  

Microsoft’s File System Watcher or, for non-Microsoft networks, by 

TEMPLACMS polling the semaphore folder every X seconds (as set  

on System Control) 

Settings Read/Write/Modify  

Shortcuts  This is where TEMPLACMS’ shortcuts are kept. Users will need permissions 

set to run the shortcuts from here if you choose to use the shortcuts folder 

for installation 

Store Read/Write/Modify  

Temp Read/Write/Modify  

Authorised users will need the above permissions to such folders and their sub-folders – these permissions (along with any 

backup requirements) must be resolved by client’s internal IT department or their external IT provider. 

Access Dimensions 

It is recommended that a separate folder area must be held on central network drive that is visible to all authorised Accounts 

users, as well as to the Access Dimensions, so that all key reports can be saved to this location, e.g. BACS payment files, period 

and year end reports (perhaps in separate sub-folders), etc.  The access to this folder must be consistent from all points which 

can be achieved as a consistently mapped drive letter or by using a full directory/folder (UNC) path.   All authorised users will 

need Read/Write/Modify permissions to such folders and their sub-folders – these permissions (along with any backup 

requirements) must be resolved by client’s internal IT department or their external IT provider. 
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Access SelectPay 

It is recommended that a separate folder area must be held on central network drive that is visible to all authorised Payroll 

users, as well as to the Access SelectPay, so that all key reports can be saved to this location, e.g. BACS payment files, pay 

period reports (preferably in separate sub-folders per payroll & pay period), FPS & EPS files, etc.  The access to this folder 

must be consistent from all points which can be achieved as a consistently mapped drive letter or by using a full 

directory/folder (UNC) path.  All authorised users will need Read/Write/Modify permissions to such folders and their sub-

folders – these permissions (along with any backup requirements) must be resolved by client’s internal IT department or their 

external IT provider. 



TEAM Software develops market-leading solutions for companies with distributed workforces. TEAM has a focus on the cleaning 

and security industries helping the companies who serve these sectors manage and optimise their business; from front line 

service delivery to back office financial management. TEAM’s technology is designed to help improve productivity, employee 

engagement and profitability, and at the same time help control cost, risk and compliance. For more information, visit 

teamsoftware.com. 

  

  

 


